summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD85
1 files changed, 58 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e91c696d3db..2a198ec5f665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,48 @@
-# Maintainer: Miguel de Val-Borro <miguel dot deval at gmail dot com>
+# Maintainer: Jan Kohnert <bughunter at jan-kohnert dot de>
+# Contributor: Miguel de Val-Borro <miguel dot deval at gmail dot com>
# Contributor: James Tappin <jtappinatgmaildotcom>
# Contributor: Gergely Imreh <imrehgATgmailDOTcom>
# Contributor: Eric Belanger <eric@archlinux.org>
pkgname=plplot
pkgver=5.15.0
-pkgrel=6
+pkgrel=7
pkgdesc="A cross-platform software package for creating scientific plots"
-arch=('i686' 'x86_64')
+arch=("i686" "x86_64")
url="http://plplot.sourceforge.net/"
license=("LGPL" "custom")
-depends=('libtool' 'tk')
-makedepends=('cmake' 'wxwidgets-gtk3')
-optdepends=('qhull: calculating convex hulls'
- 'agg: high quality rendering engine in C++'
- 'swig: connects Plplot C library to Python, Java and Lua (must be present at compile time for Java)'
- 'gd: ability to output png, jpeg and gif files'
- 'qt4: display plots, output various formats using the Qt UI framework'
- 'wxgtk: displays plots using wxWidgets library'
- 'freetype2: enables use of ttf fonts for some drivers'
- 'ttf-freefont: enables use of ttf fonts for some drivers'
- 'cairo: displays plots and save to different file formats')
-options=('!libtool' '!makeflags')
-source=(http://downloads.sourceforge.net/sourceforge/plplot/${pkgname}-${pkgver}.tar.gz plplot.patch)
-md5sums=('36aec5bfadc2e207cf8ee39f573c9303'
- '16ed4043306ce791e28ef80a80c1fbfd')
+depends=(
+ "cairo"
+ "gcc-libs"
+ "glib2"
+ "glibc"
+ "java-runtime"
+ "libtool"
+ "libx11"
+ "lua52"
+ "pango"
+ "python"
+ "python-numpy"
+ "python-pillow"
+ "qhull"
+ "qt5-base"
+ "qt5-svg"
+ "shapelib"
+ "tcl"
+ "tk"
+ "wxwidgets-common"
+ "wxwidgets-gtk3"
+)
+makedepends=("cmake" "jdk-openjdk" "pkg-config" "swig")
+optdepends=("bash")
+options=("!libtool")
+source=(
+ "http://downloads.sourceforge.net/sourceforge/plplot/${pkgname}-${pkgver}.tar.gz"
+ "plplot.patch"
+)
+sha512sums=(
+ "54533245569b724a7ef90392cc6e9ae65873e6cbab923df0f841c8b43def5e4307690894c7681802209bd3c8df97f54285310a706428f79b3340cce3207087c8"
+ "92da6a88fc626a56febb61d0fce3960ea17771e8eae4e881d708ac196ee2238909e2da07056c31e07c59ef75a7a627a629f2ca1a40ac58904bc44ff3ded042dc"
+)
prepare() {
cd "$pkgname-$pkgver"
@@ -31,25 +50,37 @@ prepare() {
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
if [ -d build ]; then
rm -r build
fi
mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_octave=off \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_ada=OFF \
+ -DENABLE_c=ON \
+ -DENABLE_cxx=ON \
+ -DENABLE_d=OFF \
+ -DENABLE_fortran=OFF \
+ -DENABLE_itcl=OFF \
+ -DENABLE_itk=OFF \
+ -DENABLE_java=ON \
+ -DENABLE_lua=ON \
+ -DENABLE_ocaml=OFF \
+ -DENABLE_octave=OFF \
+ -DENABLE_pyqt5=OFF \
+ -DENABLE_python=ON \
+ -DENABLE_qt=ON \
-DENABLE_tcl=ON \
-DENABLE_tk=ON \
-DENABLE_wxwidgets=ON \
- -DPLD_wxwidgets=ON \
- -DPL_FREETYPE_FONT_PATH=/usr/share/fonts/TTF ..
- find . -name '*.make' -exec sed -i 's|-isystem /usr/include ||g' '{}' ';'
+ -DPLD_wxwidgets=ON ..
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}/build
- make DESTDIR=${pkgdir} install
- install -D -m644 ../Copyright ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ../Copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}