summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 36 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d1b943ed20b..f0806c80343d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-#
-# Maintainer: Sebastian Lau <lauseb644@gmail.com>
+# Maintainer: Taijian <taijian@posteo.de>
+# Contributor: Sebastian Lau <lauseb644@gmail.com>
# Contributor Damian01w <damian01w@gmail.com>
# Contributor: Padfoot <padfoot@exemail.com.au>
#
pkgname=plymouth
-pkgver=0.9.4
-pkgrel=7
+pkgver=0.9.5
+pkgrel=1
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
-url="http://www.freedesktop.org/wiki/Software/Plymouth/"
-arch=('x86_64')
+url="https://www.freedesktop.org/wiki/Software/Plymouth/"
+arch=('i686' 'x86_64')
license=('GPL')
+
depends=('libdrm' 'pango' 'systemd')
makedepends=('docbook-xsl')
optdepends=('ttf-dejavu: For true type font support'
- 'xf86-video-fbdev: Support special graphic cards on early startup')
-provides=('plymouth')
-conflicts=('plymouth-git' 'plymouth-legacy' 'plymouth-nosystemd')
+ 'xf86-video-fbdev: Support special graphic cards on early startup'
+ 'cantarell-fonts: True Type support for BGRT theme')
+conflicts=('plymouth-legacy' 'plymouth-nosystemd')
backup=('etc/plymouth/plymouthd.conf')
options=('!libtool' '!emptydirs')
-source=("http://www.freedesktop.org/software/${pkgname}/releases/${pkgname}-${pkgver}.tar.xz"
+source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
'arch-logo.png'
'plymouth.encrypt_hook'
'plymouth.encrypt_install'
@@ -31,44 +32,44 @@ source=("http://www.freedesktop.org/software/${pkgname}/releases/${pkgname}-${pk
'slim-plymouth.service'
'sddm-plymouth.service'
'plymouth-deactivate.service'
- 'plymouth-read-write.service'
- 'plymouth-start.service'
+ 'plymouth-start.service.in.patch'
'plymouth-start.path'
'plymouth.initcpio_hook'
'plymouth.initcpio_install'
'sd-plymouth.initcpio_install'
'plymouth-quit.service.in.patch'
- 'plymouth-update-initrd.patch')
+ 'plymouth-update-initrd.patch'
+)
-md5sums=('4efa5551d230165981b105e7c6a50aa7'
- '1aedc14a276232311b6615f1e05d4714'
- 'd67132b297ccfb1a877a2efd78076963'
- '247b77b9b2a8e22b1e94a07462e8b23e'
- 'ae6e97bb1104bb12cbca6738e3fb872d'
- '1430ae2ec501d600f8f6771454dc9bbe'
- '870ea3e63c6989e2badf79d1fbafa914'
- 'a3cfc30df846b2d7057a29e7fbe8733a'
- 'b95f6979dc2f373045b2ab88a36d6771'
- '006847d16b852c7a50ee2f241fd9647e'
- 'cd81fba110ad5a81ad97397fe82fda52'
- '24ad6b024f8e8bb9abe13df317eb9bcb'
- '672ad913e2383483bcb4599a0a6bee48'
- '32f04fdbd1eb94ade30d1e63fdcdd9b5'
- 'c17e915b19a469198a37dd7376a846c7'
- 'af3c3eadc80e240416d11b2d5983dfb5'
- '165a39dbedcc6e123c8ca05d5b4b2e25'
- '0357775c16b5f90f1af485e6a4c80a9e')
+sha256sums=('55a461003ece0a4daeffb8b7ac2178977c5ce024a7e688d24f6d2230465b50ba'
+ 'de4369ad5a5511b684305e3a882c2c56204696514ea8ccdb556dd656eca062e7'
+ '7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120'
+ 'b6193aefa4af4449a700bca25565ba13932ceaaf6ecd72ce1ff107f6c3466ad9'
+ '0fabb974c1a301da000d5c4b9eea224ba508e577d3a6a798b67b94d4d54af255'
+ '06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d'
+ '86d0230d9393c9d83eb7bb430e6b0fb5e3f32e78fcd30f3ecd4e6f3c30b18f71'
+ '9b5534921c5bf92a9285ba53b323209e812145c204ac5fed6899b7aad78300ef'
+ '46b1c4d6c41a888e55d05d21996c4381019e91b490ed13e216b229e264a56648'
+ '3b17ed58b59a4b60d904c60bba52bae7ad685aa8273f6ceaae08a15870c0a9eb'
+ '3a46f7faced877a913506d59757f0af60ad3d5f0bc365c56ed7ecc7aef75c5eb'
+ 'ce3d62f4c5a1b5c0ccadd15406c7430251d1a42b232721bfbfc747da1b13e3ff'
+ '2a80e2cad8de428358647677afa166219589d3338c5f94838146c804a29e2769'
+ 'c7cb6fc10bc04afc8a661de4de85ebd3974bd8df695ad6043e4c9af5441bab49'
+ '0bb07ff5efa4d7b9afcedeffc35496edb7664c2a0a8030bbdc7b368c5030638d'
+ 'a1766e3fae000e5158a23b5c01d2c615894e6c3f9923877ccc5ca1bcb36351fa'
+ '74908ba59cea53c6a9ab67bb6dec1de1616f3851a0fd89bb3c157a1c54e6633a')
prepare() {
cd "$srcdir"/${pkgname}-${pkgver}
patch -p1 -i $srcdir/plymouth-update-initrd.patch
patch -p1 -i $srcdir/plymouth-quit.service.in.patch
+ patch -p1 -i $srcdir/plymouth-start.service.in.patch
}
build() {
cd "$srcdir"/${pkgname}-${pkgver}
- LDFLAGS="$LDFLAGS -ludev" ./configure \
+ LDFLAGS="$LDFLAGS -ludev" ./autogen.sh \
--prefix=/usr \
--exec-prefix=/usr \
--sysconfdir=/etc \
@@ -81,15 +82,14 @@ build() {
--enable-tracing \
--enable-pango \
--enable-gtk=no \
- --enable-tracing \
- --disable-tests \
- --with-logo=/usr/share/plymouth/arch-logo.png \
--with-release-file=/etc/os-release \
+ --with-logo=/usr/share/plymouth/arch-logo.png \
--with-background-color=0x000000 \
--with-background-start-color-stop=0x000000 \
--with-background-end-color-stop=0x4D4D4D \
--without-rhgb-compat-link \
- --without-system-root-install
+ --without-system-root-install \
+ --with-runtimedir=/run
make
}
@@ -112,8 +112,6 @@ package() {
done
install -Dm644 "$srcdir/plymouth-deactivate.service" "$pkgdir/usr/lib/systemd/system/plymouth-deactivate.service"
- install -Dm644 "$srcdir/plymouth-start.service" "$pkgdir/usr/lib/systemd/system/plymouth-start.service"
- install -Dm644 "$srcdir/plymouth-read-write.service" "$pkgdir/usr/lib/systemd/system/plymouth-read-write.service"
install -Dm644 "$srcdir/plymouth-start.path" "$pkgdir/usr/lib/systemd/system/plymouth-start.path"
install -Dm644 "$pkgdir/usr/share/plymouth/plymouthd.defaults" "$pkgdir/etc/plymouth/plymouthd.conf"
}