summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f52d578f27fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: svalo <me@valo.space>
+pkgname=plzip
+pkgver=1.5
+pkgrel=1
+pkgdesc="A massively parallel lossless data compressor based on the lzlib compression library"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/lzip/plzip.html"
+license=('GPL')
+depends=('lzlib')
+source=("http://download.savannah.gnu.org/releases/lzip/plzip/$pkgname-$pkgver.tar.gz")
+md5sums=('504d46ba468d337ec6c42f3c583632ba')
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}