summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83101b7f5754..a64fad0a9f99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: katt <magunasu.b97@gmail.com>
+
pkgname=pmbootstrap-git
-pkgver=1.29.2.r11.gaf2b2b59
+pkgver=1.42.0.r12.gfaf52391
pkgrel=1
pkgdesc='Sophisticated chroot/build/flash tool to develop and install postmarketOS (git)'
arch=(any)
url=https://postmarketos.org
license=(GPL)
depends=(python-setuptools)
-makedepends=(git)
+makedepends=(python-build python-installer python-wheel git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+https://gitlab.com/postmarketOS/pmbootstrap.git)
@@ -20,10 +21,10 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname%-git}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}