summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7a1f69045ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Mainintainer : Lucas Rooyakkers <lucas dot rooyakkers at pm dot me>
+pkgname=pnglatex
+pkgver=de1de3c
+pkgrel=1
+pkgdesc="Small script to turn LaTeX formulas into png images"
+arch=('any')
+url="https://github.com/mneri/pnglatex"
+license=('GPL3')
+depends=('texlive-bin' 'imagemagick' 'optipng')
+optdepends=('xorg-xdpyinfo: get dpi resolution of screen')
+provides=("pnglatex")
+conflicts=('pnglatex')
+md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/mneri/pnglatex")
+
+pkgver() {
+ cd "$pkgname"
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "pnglatex" "${pkgdir}/usr/bin/pnglatex"
+ install -Dm755 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: