summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..508dc92839d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=pngslice
+pkgver=0.66
+pkgrel=1
+pkgdesc="The program performs this slicing for png images and writes a fragment of html to handle the image inclusion."
+arch=('i686' 'x86_64')
+url="http://sview01.wiredworkplace.net/pub/jjg/en/code/pngslice.html"
+license=('GPL')
+depends=('libpng')
+source=(http://sview01.wiredworkplace.net/pub/jjg/code/$pkgname.tar.gz)
+
+md5sums=('816313410dee225f417765b1af0e6186')
+
+build() {
+ cd "${srcdir}/$pkgname"
+
+ ./configure --prefix=/usr
+ make || return 1
+# doesn't work yet: make DESTDIR="${pgkdir}" install
+
+ install -D -m755 "src/$pkgname" "${pkgdir}/usr/bin/$pkgname" || return 1
+ install -D -m644 "src/$pkgname.1" "${pkgdir}/usr/share/man/man1/$pkgname.1" || return 1
+}