summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5b59410bd9d..d8a3e4f18e6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=pnmixer
-pkgver=0.7
+pkgver=0.7.2
pkgrel=1
pkgdesc="GTK volume mixer applet that runs in the system tray."
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/nicklan/pnmixer"
-makedepends=('intltool')
+makedepends=('intltool' 'cmake')
depends=('gtk2' 'alsa-lib' 'libnotify')
-source=("https://github.com/nicklan/pnmixer/releases/download/v0.7/pnmixer-${pkgver}.tar.gz")
-md5sums=('4ddfab98ad915075aecced01e0890c65')
+source=("https://github.com/nicklan/pnmixer/releases/download/v${pkgver}/pnmixer-v${pkgver}.tar.gz")
+md5sums=('e9f17f56c50de39393030a96e343427b')
build() {
- cd $pkgname-$pkgver
- ./autogen.sh --without-gtk3 --prefix=/usr
- make V=0
+ cd $pkgname-v$pkgver
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DWITH_GTK3=OFF
+ make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname-v$pkgver
make DESTDIR="$pkgdir" install
}