summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 19 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4289868d659..2b311d491fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,36 @@
-# Maintainer: Marco Pompili <aur AT emarcs DOT org>
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: éclairevoyant
+# Contributor: Marco Pompili <aur AT emarcs DOT org>
# Contributor: Ben Duffield <bavardage AT archlinux.us>
-# Contributor: Martchus <martchus@gmx.net>
pkgname=pocketsphinx
-pkgver=5prealpha
-pkgrel=10
-pkgdesc='Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.'
+pkgver=5.0.3
+pkgrel=1
+pkgdesc='A small speech recognizer'
arch=('i686' 'x86_64')
-url='http://cmusphinx.sourceforge.net'
-license=('BSD')
-makedepends=('swig' 'python2' 'python')
-depends=('sphinxbase=5prealpha' 'gst-plugins-base-libs')
-source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz")
-sha256sums=('ef5bb5547e2712bdf571f256490ef42a47962033892efd9d7df8eed7fe573ed9')
-options=('!libtool')
+url='https://cmusphinx.github.io'
+license=('BSD' 'MIT')
+makedepends=('cmake' 'ninja' 'gst-plugins-base-libs')
+optdepends=('gst-plugins-base-libs: GStreamer plugin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/cmusphinx/pocketsphinx/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('5d952cb1c22e0a51ed1fafc36871612df38f145df64fa017fdc8074532ec007f')
prepare() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
- msg2 "Reconfiguring project for current version of Automake"
- autoreconf -ivf > /dev/null
-
- cd ..
-
- cp -R "$pkgname-$pkgver" "$pkgname-$pkgver-py2"
- cp -R "$pkgname-$pkgver" "$pkgname-$pkgver-py3"
}
build() {
+ cd $pkgname-$pkgver
- msg2 "Building python3 environment"
- export PYTHON=/usr/bin/python
- cd "$pkgname-$pkgver-py3"
- ./configure --prefix=/usr
- make
-
-
- msg2 "Building python2 environment"
- cd "../$pkgname-$pkgver-py2"
- export PYTHON=/usr/bin/python2
- ./configure --prefix=/usr
- make
+ cmake -S . -B build -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -DBUILD_GSTREAMER=ON
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver-py3"
-
- make DESTDIR="$pkgdir" install
+ cd $pkgname-$pkgver
- cd "../$pkgname-$pkgver-py2/swig"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
- install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}