summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46cda0abd625..8c00942c62d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=poi
_pkgname=poi
-pkgver=10.3.0.0.g9c7f0982
-pkgrel=2
+pkgver=10.9.2.0.g69d7ab10
+pkgrel=1
pkgdesc="Scalable KanColle browser and tool"
arch=('any')
url="https://github.com/poooi/poi/"
license=('MIT')
-depends=('npm' 'sh' 'electron')
-makedepends=('git' 'nodejs' 'coreutils' 'findutils' 'sed' 'imagemagick' 'tar' 'zlib' 'unzip' 'gulp' 'npm' 'python2')
+depends=('nodejs' 'nss' 'libxss' 'gtk3')
+makedepends=('git' 'nodejs' 'imagemagick' 'zlib' 'unzip' 'gulp' 'npm' 'python2' 'jq')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+https://github.com/poooi/poi.git"
@@ -17,13 +17,13 @@ source=("git+https://github.com/poooi/poi.git"
"${_pkgname}.sh")
sha256sums=('SKIP'
'24f89c538a189a5db96be3e3228aba6e4e7d332c5a368b15dacb6e97ee6f7586'
- 'f6c559d512379263b77a043e668eb846c53f5487fc932c1003f08c7dc1ad14e2')
+ '6d7f8d85eff0262cd21a506900352894c925821e26b79923664b2c2a3ab0097a')
options=('!strip') # nothing to strip
prepare() {
cd ${srcdir}/${pkgname}
- git checkout -f $(git describe --tags $(git rev-list --tags --max-count=1))
+ git checkout -f $(git tag --sort=-taggerdate | egrep -v '.*(alpha|beta).*' | head -n 1)
}
pkgver() {
@@ -36,6 +36,9 @@ build() {
git clean -xdf
npm install
gulp build
+ # bundle electron
+ cd app_compiled
+ npm i electron@$(jq -r '.devDependencies.electron' ../package.json)
}
package() {
@@ -58,4 +61,6 @@ package() {
mkdir -p "${pkgdir}/usr/bin"
cp "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
chmod 0755 "${pkgdir}/usr/bin/${_pkgname}"
+
+ find "${pkgdir}" -type f -name .DS_Store -delete
}