summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0195678e655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hyperdriveguy <hyperdriveguy@gmail.com>
+pkgname=polished-map-plus-plus
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="A map and tileset editor for pokecrystal, pokered, and hacks based on them like Polished Crystal (attributes support)."
+arch=('x86_64')
+url='https://github.com/Rangi42/polished-map'
+license=('LGPL')
+depends=('fltk-mod')
+makedepends=('git' 'make' 'gcc')
+source=("${pkgname}"::'git+https://github.com/Rangi42/polished-map.git')
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ git checkout ff48bf6
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}