summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0e617aa49d4..a27b32b405f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,40 @@
pkgname=pology
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc='A framework for custom processing of PO files.'
arch=('any')
license=('GPL3')
-url='http://techbase.kde.org/Localization/Tools/Pology'
+url='https://invent.kde.org/sdk/pology'
depends=('python2' 'gettext')
makedepends=('cmake' 'libxml2' 'docbook-xsl' 'epydoc' 'python2-pygments')
options=(!makeflags)
optdepends=('python2-dbus: to communicate with external applications'
- 'python2-pyenchant: spell checking functionality (needs a dictionary)'
- 'hunspell-lang: a spell-checking dictionary for your language(s)'
- 'aspell-lang: a spell-checking dictionary for your language(s)'
- 'ispell-lang: a spell-checking dictionary for your language(s)'
- 'languagetool: used by the check-grammar sieve'
- 'apertium: used by the pomtrans script'
- 'git: for processing files under version control'
- 'subversion: for processing files under version control')
-conflicts=('pology-svn')
+ 'python2-pyenchant: spell checking functionality (needs a dictionary)'
+ 'hunspell-lang: a spell-checking dictionary for your language(s)'
+ 'aspell-lang: a spell-checking dictionary for your language(s)'
+ 'ispell-lang: a spell-checking dictionary for your language(s)'
+ 'languagetool: used by the check-grammar sieve'
+ 'apertium: used by the pomtrans script'
+ 'git: for processing files under version control'
+ 'subversion: for processing files under version control')
+conflicts=('pology-git')
changelog=changelog
-source=(http://pology.nedohodnik.net/release/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('33fd75b7214fc70882df128b5651d4870cb7d6cc73ca27c5517b4686976de5de')
+source=(https://invent.kde.org/sdk/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.bz2)
+sha256sums=('a49396eb854165f82bb22575301e890e1eead04ac86f98fff8533c486d07236a')
prepare() {
sed -i -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' $(find ${srcdir} -name '*.py')
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DDOCBOOK_XSL_DIR=/usr/share/xml/docbook/xsl-stylesheets-1.78.1/
+ cd ${srcdir}/${pkgname}-v${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-v${pkgver}
make DESTDIR="${pkgdir}" install
install -d ${pkgdir}/usr/share/apps/katepart/syntax