summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b154d5bded5..cf3fe79478bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Patrick Ziegler <p.ziegler96@gmail.com>
pkgname=polybar
-pkgver=3.5.7
-pkgrel=2
+pkgver=3.6.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
+# aarch64 is not officially supported by polybar, it is only listed here for convenience
arch=("i686" "x86_64" "aarch64")
url="https://github.com/polybar/polybar"
license=("MIT")
-depends=("cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm" "xcb-util-cursor"
- "alsa-lib" "libpulse" "libmpdclient" "libnl" "jsoncpp" "curl")
-optdepends=("i3-wm: i3 module support"
- "ttf-unifont: Font used in example config"
- "siji-git: Font used in example config"
- "xorg-fonts-misc: Font used in example config")
+depends=("libuv" "cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm"
+ "xcb-util-cursor" "alsa-lib" "libpulse" "libmpdclient" "libnl"
+ "jsoncpp" "curl")
+optdepends=("i3-wm: i3 module support")
makedepends=("cmake" "python" "pkg-config" "python-sphinx" "python-packaging" "i3-wm")
conflicts=("polybar-git")
-install="${pkgname}.install"
source=(${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('73210e6d74217acb953b253990b4302343b7b6a7870fe1da9a1855daa44123db')
+sha256sums=('563473d5ae2b83d4dba6372f85cbcfd8d5a271b4cf3345ff57acff9c81e1b065')
_dir="${pkgname}-${pkgver}"
prepare() {