summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5981a0ba6afe..8253ef3edd1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Carlberg <c@rlberg.se>
pkgname=polybar
pkgver=3.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/jaagr/polybar"
@@ -16,7 +16,7 @@ optdepends=("alsa-lib: volume module support"
"ttf-unifont: Font used in example config"
"siji-git: Font used in example config"
"curl: github module support")
-makedepends=("cmake" "git" "python" "python2" "pkg-config")
+makedepends=("clang" "cmake" "git" "python" "python2" "pkg-config")
conflicts=("polybar-git")
install="${pkgname}.install"
source=("${pkgname}::git+${url}.git#tag=${pkgver}")
@@ -29,7 +29,7 @@ prepare() {
build() {
cd "${pkgname}/build" || exit 1
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_COMPILER="clang" -DCMAKE_CXX_COMPILER="clang++" ..
cmake --build .
}