summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b06fe1f0d8c2..8caef53bfe59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=polymc
pkgname=${_pkgname}-git
-pkgver=1.4.0.r301.gc97a47dc
-pkgrel=3
+pkgver=1.4.0.r348.gc089f9b5
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/PolyMC/PolyMC"
@@ -15,7 +15,7 @@ license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
provides=('polymc')
conflicts=('polymc')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
@@ -36,9 +36,10 @@ pkgver() {
prepare() {
cd "PolyMC"
git submodule init
- git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.depends/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
+ git config submodule.libraries/filesystem.active false
git submodule update
}