summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 326c6eb94076..5707b5772a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
set -u
_pkgname='pom-ng'
pkgname="${_pkgname}-git"
-pkgver=0.0.19.r0.g48da973
+pkgver=0.0.19.r2.gcb92fb7
pkgrel=1
pkgdesc='Packet-o-Matic real time network packet capture forensic tool'
arch=('i686' 'x86_64')
@@ -33,7 +33,8 @@ conflicts=("${_pkgname}")
_srcdir="${pkgname^^}"
_giturl="https://github.com/gmsoft-tuxicoman/${_pkgname}"
_verwatch=("${_giturl}/releases.atom" '\s\+<title>v\([^<]\+\).*' 'f') # RSS
-source=("${_srcdir}::${_giturl//https:/git:}.git")
+source=("${_srcdir}::git+${_giturl}.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
pkgver () {
@@ -43,26 +44,19 @@ pkgver () {
set +u
}
-prepare() {
- set -u
- cd "${_srcdir}"
- autoreconf -f -i
- lua_CFLAGS="$(pkg-config --cflags lua51)" \
- lua_LIBS="$(pkg-config --libs lua51)" \
- ./configure --prefix='/usr'
- #cp -p '/usr/include/libexif/exif-data.h' .
- set +u
-}
-
build() {
set -u
cd "${_srcdir}"
- if [ ! -z "${MAKEFLAGS:-}" ] && [ "${MAKEFLAGS}" != "${MAKEFLAGS//-j/}" ]; then
- nice make -s
- else
- local _nproc="$(lscpu -p | grep '^[0-9]' | cut -d',' -f2-3 | sort -u | wc -l)"; _nproc=$((_nproc>4?4:_nproc))
- nice make -s -j "${_nproc}"
+ if [ ! -s 'configure' ]; then
+ autoreconf -f -i
+ fi
+ if [ ! -s 'Makefile' ]; then
+ lua_CFLAGS="$(pkg-config --cflags lua51)" \
+ lua_LIBS="$(pkg-config --libs lua51)" \
+ ./configure --prefix='/usr'
+ #cp -p '/usr/include/libexif/exif-data.h' .
fi
+ nice make -s
set +u
}