summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f0fb1bda118..4ff364d62858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
pkgname=ponscripter-bin
-pkgver=v3.0.2
-_pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
+pkgver=4.0.0
pkgrel=1
-pkgdesc="Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration"
+pkgdesc='Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration'
arch=(x86_64 aarch64)
url=https://github.com/07th-mod/ponscripter-fork
license=(GPL)
depends=(sdl2_mixer freetype2)
depends_aarch64=(box64)
provides=(ponscripter)
-conflicts=(ponscripter)
-source=(`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep browser_download_url|cut -d\" -f4|grep 'linux\.'`)
-md5sums=(SKIP)
-pkgver(){
- echo $_pkgver
-}
+conflicts=($provides)
+options=(!strip)
+source=($url/releases/download/v$pkgver/ponscr-$pkgver-linux.zip)
+cksums=(SKIP)
package(){
[ $CARCH = x86_64 ] && install ponscr -Dt "$pkgdir"/usr/bin || {
- install ponscr -D "$pkgdir"/usr/bin/ponscr-x86_64
- echo -e '#!/bin/sh\nbox64 ponscr-x86_64 "$@"'>"$pkgdir"/usr/bin/ponscr # force box64 if binfmt is missing
+ install ponscr -D "$pkgdir"/usr/bin/ponscr.bin
+ echo -e '#!/bin/sh\nbox64 ponscr.bin "$@"'>"$pkgdir"/usr/bin/ponscr # force box64 if binfmt is missing
chmod +x "$pkgdir"/usr/bin/ponscr
}
}