summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbb7528fe2a3..e7cb4698969d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Maintainer: Christopher Reimer <mail at c-reimer dot de>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: Carl George < carl at george dot computer >
-pkgname='pop-gtk-theme'
-pkgver='2.2.3'
-_pkgver="${pkgver}-0"
+pkgname=pop-gtk-theme
+pkgver=5.4.4
pkgrel=1
-pkgdesc='Version 2 of the Pop GTK+ Theme'
+pkgdesc="System76 Pop GTK+ Theme"
arch=('any')
-url='https://github.com/system76/pop-gtk-theme'
-license=('GPL2' 'CCPL:by-sa')
-makedepends=('sassc' 'optipng' 'parallel')
-source=("${pkgname}-${_pkgver}.tar.gz::${url}/archive/${_pkgver}/${pkgname}-${_pkgver}.tar.gz")
-sha256sums=('910759e857f9bbd376d9db54b9119f49f78af782cb7f75d2df84a3f22a675de8')
+url='https://github.com/pop-os/gtk-theme'
+license=('LGPL2.1' 'CCPL' 'GPL3')
+makedepends=('sassc' 'meson')
+source=("https://github.com/pop-os/gtk-theme/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('98aee760f11da91a8a3e2900070ee591b5150e542e967fad17419947607a325b26132b14a25b472f2124d0ad5ef56050de8030e6f1a80cbd8f1361df32fbd64f')
build() {
- cd "${pkgname/pop-}-${_pkgver}"
-
- make
+ cd "gtk-theme-${pkgver}"
+ meson --prefix='/usr' build
+ ninja -C build
}
package() {
- cd "${pkgname/pop-}-${_pkgver}"
+ cd "gtk-theme-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
- make DESTDIR="${pkgdir}" install
+ # https://github.com/pop-os/gtk-theme/issues/436
+ ln -s /usr/share/gnome-shell/theme/Pop-dark "${pkgdir}/usr/share/themes/Pop-dark/gnome-shell"
}
-# vim: ts=2 sw=2 et: