summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ef828ed486f..bf8d0261d81e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,7 @@ build() {
package_popsift() {
pkgdesc+=" [development headers and static libs]"
- depends=('boost')
+ depends=('boost' "popsift-libs=${pkgver}")
optdepend=('cuda: for static cudart library')
options=('staticlibs')
make -C "$srcdir/build_static" DESTDIR="${pkgdir}" install
@@ -59,6 +59,7 @@ package_popsift() {
package_popsift-libs() {
depends=('boost-libs>=1.55' 'libcudart.so')
+ provides=("popsift-libs=${pkgver}")
cd
make -C "${srcdir}/build_shared" DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}"/usr/{include,shared,lib/cmake}