summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54a939604dd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Thomas Arnhold <thomas@arnhold.org>
+# Contributor: Ariel Popper <a@arielp.com>
+# Contributor: Dan McGee <dan@archlinux.org>
+
+pkgname=postgresql-92-upgrade
+pkgver=9.2.24
+_majorver=${pkgver%.*}
+pkgrel=1
+pkgdesc="PostgreSQL build for migrating between major versions with pg_upgrade"
+arch=('i686' 'x86_64')
+url="http://www.postgresql.org/"
+license=('custom:PostgreSQL')
+depends=("postgresql-libs>=${_majorver}" 'libxml2' 'openssl>=1.0.0' 'pam')
+makedepends=('krb5' 'python2' 'perl' 'tcl>=8.6.0')
+provides=("postgresql-92-upgrade=${_majorver}")
+conflicts=('postgresql-old-upgrade' 'postgresql-lts-old-upgrade')
+source=(http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2)
+sha256sums=('a754c02f7051c2f21e52f8669a421b50485afcde9a581674d6106326b189d126')
+
+build() {
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ ./configure \
+ --prefix=/opt/pgsql-${_majorver} \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --without-readline \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --disable-nls \
+ --enable-thread-safety
+
+ make -C src all
+ make -C contrib all
+}
+
+package() {
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install
+ make -C src DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/opt/pgsql-${_majorver}/include/"
+}
+