summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 276a0b085a8b..1b4a2b29646f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Radek Podgorny <radek@podgorny.cz>
# Thomas Haider <t.haider@deprecate.de>
# maintainer: fordprefect <fordprefect@dukun.de>
+# contributor: bertptrs
pkgname=postsrsd
pkgver=1.6
-pkgrel=3
+pkgrel=4
pkgdesc="Provides the Sender Rewriting Scheme (SRS) via TCP-based lookup tables for Postfix"
arch=('i686' 'x86_64' 'armv7h')
depends=('glibc')
@@ -15,10 +16,22 @@ url="https://github.com/roehling/postsrsd"
install=postsrsd.install
license=(GPL2)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/roehling/postsrsd/archive/${pkgver}.tar.gz"
+ "${pkgname}-systemd-detect.patch::https://github.com/roehling/postsrsd/commit/a483cb48aa32b87ab4d277d31b3855021e144951.patch"
"postsrsd.conf")
md5sums=('cf6709cff63d1f3d7f1d06aede82bdb3'
+ 'a163bdcf2d7a84d41bc891ce07694c16'
'81a5eea5b84f3a2de9ad4713512175f0')
+prepare() {
+ cd "$srcdir/postsrsd-$pkgver"
+ patch -p1 < "${srcdir}/${pkgname}-systemd-detect.patch"
+}
+
+check() {
+ cd "$srcdir/postsrsd-$pkgver/build"
+ make test
+}
+
build() {
cd "$srcdir/postsrsd-$pkgver"
[[ -d build ]] && rm -rf build