summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 23 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 830087d366ac..9c914e45bbfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-# Maintainer: Synhme <dmitry@synh.me>
+# Maintainer: Ykkzde <dmitry@ykkz.de>
pkgname=posy-cursors
-pkgver=3.7
-pkgrel=3
+pkgver=3.7.10
+pkgrel=1
pkgdesc="Port of Posy's improved cursors"
arch=(any)
-url="https://git.synh.me/dmitry/posy-cursors"
+url="https://gitlab.com/ykkzde/posy-cursors"
license=(unknown)
-source=("$pkgname-$pkgver.tar.gz::https://git.synh.me/dmitry/posy-cursors/-/archive/v3.7/posy-cursors-v3.7.tar.gz?path=themes")
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/v$pkgver/posy-cursors-v$pkgver.tar.gz?path=themes") # automatically set in CI, see: /.gitlab-ci.yml
-sha256sums=('3c4b7e4293143057e7a5a90b63bebee9c785ca4552e5dddbf538b8322036d471')
+sha256sums=('SKIP') # automatically set in CI, see: /.gitlab-ci.yml
package() {
- cd posy-cursors-v$pkgver-themes/themes
- install -Ddm755 "$pkgdir/usr/share/icons"
- cp -dr --no-preserve=ownership posy-white/ "$pkgdir/usr/share/icons/posy-white"
- cp -dr --no-preserve=ownership posy-black/ "$pkgdir/usr/share/icons/posy-black"
- cp -dr --no-preserve=ownership posy-white-tiny/ "$pkgdir/usr/share/icons/posy-white-tiny"
- cp -dr --no-preserve=ownership posy-black-tiny/ "$pkgdir/usr/share/icons/posy-black-tiny"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ ls -l
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ ls -l *
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ cd $pkgname-v$pkgver-themes/themes
+ install -Ddm755 "$pkgdir/usr/share/icons"
+ cp -dr --no-preserve=ownership posy-white/ "$pkgdir/usr/share/icons/posy-white"
+ cp -dr --no-preserve=ownership posy-black/ "$pkgdir/usr/share/icons/posy-black"
+ cp -dr --no-preserve=ownership posy-white-tiny/ "$pkgdir/usr/share/icons/posy-white-tiny"
+ cp -dr --no-preserve=ownership posy-black-tiny/ "$pkgdir/usr/share/icons/posy-black-tiny"
}