summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1264e95d1e67..2b26b627965c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,12 @@ depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
makedepends=('git' 'nlohmann-json')
source=(
"git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
+ "spuce-qt-workaround.diff"
"PothosFlow.desktop"
)
sha256sums=(
'SKIP'
+ '3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f'
'4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
)
@@ -23,7 +25,10 @@ prepare() {
cd "$srcdir/PothosCore"
git submodule init
git submodule deinit poco
- git submodule update --recursive
+ git submodule update --recursive --force
+
+ cd spuce
+ git apply "$srcdir/spuce-qt-workaround.diff"
}
build() {