summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fa740460ef9..78ece7da1843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Remi Gacogne <rgacogne-arch at archlinux dot org>
pkgname=powerdns-recursor-git
-pkgver=4.5.0alpha0.r133.gfb8b7ee85
+pkgver=5.0.0alpha1.r2.g1116ade49
pkgrel=1
pkgdesc='Resolving DNS server'
arch=('x86_64')
@@ -10,11 +10,12 @@ source=("${pkgname}::git+https://github.com/PowerDNS/pdns"
sysusers.conf)
sha512sums=('SKIP'
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72')
-makedepends=('boost' 'git' 'pandoc' 'python-virtualenv' 'ragel' 'systemd')
-depends=('boost-libs' 'fstrm' 'libsodium' 'libsystemd' 'luajit' 'net-snmp' 'openssl' 'protobuf' )
+makedepends=('boost' 'git' 'pandoc' 'python-virtualenv' 'ragel' 'rust' 'systemd' 'lld')
+depends=('boost-libs' 'fstrm' 'libboost_context.so' 'libcurl.so' 'libsodium' 'systemd-libs' 'luajit' 'net-snmp' 'openssl')
provides=('powerdns-recursor')
conflicts=('powerdns-recursor')
backup=('etc/powerdns/recursor.conf')
+options=(!lto)
prepare() {
cd "${pkgname}/pdns/recursordist"
@@ -35,9 +36,11 @@ build() {
--disable-silent-rules \
--enable-reproducible \
--enable-systemd \
- --with-protobuf \
+ --enable-dns-over-tls \
--with-libsodium \
--with-lua=luajit \
+ --with-net-snmp \
+ --enable-auto-var-init=zero \
--with-service-user=pdns-recursor \
--with-service-group=pdns-recursor
make
@@ -47,9 +50,7 @@ package() {
cd "${pkgname}/pdns/recursordist/"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/etc/powerdns/recursor.conf-dist" "${pkgdir}/etc/powerdns/recursor.conf"
-
- cd "${srcdir}"
- install -D -m644 sysusers.conf "${pkgdir}/usr/lib/sysusers.d/powerdns-recursor.conf"
+ install -Dm 644 "${srcdir}/sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/powerdns-recursor.conf"
}
# vim: ts=2 sw=2 et: