summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6d41d51fdeb..f60da78d0ae3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
+# Maintainer: Philip Wellnitz
+
pkgname=powerline-i3-git
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="The ultimate statusline/prompt utility. A fork containing more features for the i3 window manager."
arch=('i686' 'x86_64')
url="https://github.com/ph111p/powerline"
license=('MIT')
depends=(
'python'
- 'powerline-fonts-git'
- 'lemonbar-xft-git'
+ 'powerline-fonts'
'ttf-font-awesome-4'
+ 'lemonbar-xft-git'
+ 'i3ipc-python-git'
+ 'xorg-xrandr'
)
optdepends=(
- 'i3ipc-python-git: workspace segment'
- 'wpa_actiond: wireless segment'
- 'wireless_tools: wireless segment'
'python-iwlib: wireless segment'
'python-pyalsaaudio: volume segment'
'python-psutil: cpu load segment'
'python-pygit2: better git performance of the vcs segment'
'python-google-api-python-client: Google Calendar support for the appoints segment'
- 'xorg-xrandr: RandR segment'
- 'xorg-xinput: RandR segment'
+ 'xorg-xinput: screen rotation segment'
+ 'python-xlib: Use Xlib instead of xrandr (experimental)'
)
makedepends=(
'python-setuptools'
)
provides=('powerline-i3')
conflicts=('powerline' 'python-powerline')
-install=$pkgname.install
source=("git://github.com/ph111p/powerline.git")
sha512sums=('SKIP')
@@ -37,4 +37,11 @@ package() {
cd powerline
python setup.py install --root="${pkgdir}" --optimize=1
+
+ echo ">>> To use powerline instead of i3bar, replace"
+ echo ">>> bar {"
+ echo ">>> status_command i3status"
+ echo ">>> }"
+ echo ">>> in your i3/config with this line:"
+ echo ">>> exec_always \"killall powerline-lemonbar; powerline-lemonbar --i3 --height 16 -- -a 40 -b -f \'DejaVu Sans Mono-11\' -f \'PowerlineSymbols-12\' -f \'FontAwesome-11\'\""
}