summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3ac2890644c..fdf62b24613f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+# Contributor: Max Liebkies <mail@maxliebkies.de>
pkgname=powershell
-_pkgver=6.0.0-beta.3
+_pkgver=6.0.0-beta.5
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (latest release)"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet-sdk-2.0')
+makedepends=('git' 'cmake' 'dotnet-sdk-2.0')
depends=('icu')
conflicts=('powershell-git')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
- googletest::git+https://github.com/google/googletest.git
- os-release)
+ googletest::git+https://github.com/google/googletest.git)
md5sums=('SKIP'
'SKIP'
- 'SKIP'
- 'f5841baa62b1322c07f9394940cec818')
+ 'SKIP')
install=powershell.install
prepare() {
@@ -28,6 +27,8 @@ prepare() {
git config submodule.src/libpsl-native/test/googletest.url "$srcdir"/googletest
git submodule update
git clean -dfx
+
+ sed -i -e 's/hash powershell/\/bin\/false/g' build.sh
}
build() {
@@ -38,15 +39,12 @@ build() {
make -j
popd
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
+ "$srcdir"/powershell/build.sh
}
check() {
cd $pkgname/src/libpsl-native
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release \
make test
}
@@ -55,12 +53,12 @@ package() {
cd $pkgname/src/powershell-unix
mkdir -p "$pkgdir"/usr/lib/$pkgname
- cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$pkgname
- chmod 755 "$pkgdir"/usr/lib/$pkgname/ubuntu.16.04-x64/$pkgname
+ cp -a bin/Linux/netcoreapp*/linux-x64 "$pkgdir"/usr/lib/$pkgname
+ chmod 755 "$pkgdir"/usr/lib/$pkgname/linux-x64/$pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/$pkgname "$pkgdir"/usr/bin/powershell
+ ln -s /usr/lib/$pkgname/linux-x64/$pkgname "$pkgdir"/usr/bin/powershell
}