summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 711b7530e102..c4c1e9d45050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,22 @@
pkgname=powershell
_pkgver=6.0.0-alpha.18
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet' 'dotnet-cli' 'dotnet-sdk')
-depends=('bash' 'icu55')
+makedepends=('git' 'cmake' 'proot' 'dotnet' 'dotnet-sdk')
+depends=('bash' 'icu')
conflicts=('powershell-git')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
googletest::git+https://github.com/google/googletest.git
- os-release
- build.sh)
+ os-release)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'f5841baa62b1322c07f9394940cec818'
- 'd20378ea8504200919c65de6592f0b24')
+ 'f5841baa62b1322c07f9394940cec818')
prepare() {
cd $pkgname
@@ -42,7 +40,7 @@ build() {
popd
PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/build.sh
+ proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
}
check() {
@@ -59,10 +57,11 @@ package() {
mkdir -p "$pkgdir"/usr/lib/$pkgname
cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$pkgname
+ chmod +x "$pkgdir"/usr/lib/$pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
+ ln -s "$pkgdir"/usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
}