summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 13 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfa54878920c..13bdfe43e4a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=ppsspp-git
pkgname=('ppsspp-git' 'ppsspp-qt-git')
-pkgver=1.0.1.r599.0597b92
+pkgver=1.0.1.r2617.cf0697e
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=('i686' 'x86_64')
@@ -17,14 +17,10 @@ depends=('ffmpeg' 'sdl2')
makedepends=('cmake' 'git' 'glu' 'qt5-tools')
source=('git+https://github.com/hrydgard/ppsspp.git'
'git+https://github.com/hrydgard/ppsspp-lang.git'
- 'ppsspp-native::git+https://github.com/hrydgard/native.git'
- 'ppsspp-armips::git+https://github.com/Kingcom/armips.git'
- 'ppsspp-gcc5.1.patch')
+ 'ppsspp-armips::git+https://github.com/Kingcom/armips.git')
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- '719f6ae3efa533872f1db5131bc9e7245d7c2e40e776c9869a0820be17f0ac9d')
+ 'SKIP')
pkgver() {
cd ppsspp
@@ -35,22 +31,22 @@ pkgver() {
prepare() {
cd ppsspp
- for submodule in native lang ext/armips; do
+ for submodule in lang ext/armips; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git submodule update ${submodule}
done
- patch -Np1 -i ../ppsspp-gcc5.1.patch
+ for ui in sdl qt; do
+ if [[ -d build-$ui ]]; then
+ rm -rf build-$ui
+ fi
+ mkdir build-$ui
+ done
}
build() {
- cd ppsspp
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
+ cd ppsspp/build-sdl
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
@@ -58,12 +54,7 @@ build() {
-DUSE_SYSTEM_FFMPEG='TRUE'
make
- cd ..
-
- if [[ -d build-qt ]]; then
- rm -rf build-qt
- fi
- mkdir build-qt && cd build-qt
+ cd ../build-qt
qmake-qt5 CONFIG+='release' CONFIG+='system_ffmpeg' ../Qt/PPSSPPQt.pro
make
@@ -73,7 +64,7 @@ package_ppsspp-git() {
provides=('ppsspp')
conflicts=('ppsspp' 'ppsspp-qt' 'ppsspp-qt-git')
- cd ppsspp/build
+ cd ppsspp/build-sdl
install -dm 755 "${pkgdir}"/usr/{bin,share/{applications,man/man1,pixmaps,ppsspp}}
install -m 755 PPSSPPSDL "${pkgdir}"/usr/bin/ppsspp