summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8ab7839781
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Alexander Rundberg <alexanderrundberg [at] fastmail [dot] jp>
+pkgname=pretty-git-prompt
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Pretty git status for your shell prompt"
+arch=('any')
+url="https://github.com/TomasTomecek/pretty-git-prompt"
+license=('MIT')
+depends=('git')
+makedepends=('rust')
+source=("https://github.com/TomasTomecek/pretty-git-prompt/archive/$pkgver.tar.gz")
+md5sums=('de78492d10f69c9946ecec184ea00398')
+
+
+package() {
+ cd "$srcdir"/"$pkgname"-"$pkgver"
+ make exec-stable-build
+ install -Dm755 target/release/pretty-git-prompt "$pkgdir"/usr/bin/pretty-git-prompt
+}