summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 27 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aec3eee27f73..38ae94a928d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,26 +9,24 @@
pkgname=prosody-hg
pkgrel=1
-pkgver=r9637+.b8301ba2c437+
-pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
-}
+pkgver=r11977+.10cdfb94f1cc+
pkgdesc="Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)"
arch=('i686' 'x86_64' 'armv7h')
url="https://prosody.im/"
license=('MIT')
-depends=('lua51' 'lua51-socket' 'lua51-expat' 'lua51-filesystem' 'libidn'
- 'openssl')
+depends=(
+ 'icu'
+ 'lua'
+ 'lua-socket'
+ 'lua-expat'
+ 'lua-filesystem'
+ 'lua-sec')
makedepends=('mercurial')
-checkdepends=('luacheck' 'shellcheck' 'lua52-posix' 'lua52-sec')
+checkdepends=('luacheck' 'shellcheck' 'lua-posix' 'lua-sec')
conflicts=('prosody')
provides=('prosody')
optdepends=(
-'lua51-sec: TLS encryption support'
-'lua51-bitop: websocket support'
-'lua51-event: libevent support'
-)
+ 'lua-event: libevent support')
install=prosody.install
backup=('etc/prosody/prosody.cfg.lua')
source=("prosody-hg::hg+https://hg.prosody.im/trunk"
@@ -36,42 +34,35 @@ source=("prosody-hg::hg+https://hg.prosody.im/trunk"
'sysuser.conf'
'prosody.service')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
prepare() {
cd ${pkgname}
# disable logging to output and activate syslog
- sed -i s/"info = "/"-- info = "/g prosody.cfg.lua.dist
- sed -i s/"error = "/"-- error = "/g prosody.cfg.lua.dist
- sed -i s/"--\ \"\*syslog\"\;"/"\"*syslog\"\;"/g prosody.cfg.lua.dist
+ sed -i s/"info = "/"-- info = "/g prosody.cfg.lua.dist
+ sed -i s/"error = "/"-- error = "/g prosody.cfg.lua.dist
+ sed -i s/"--\ \"\*syslog\"\;"/"\"*syslog\"\;"/g prosody.cfg.lua.dist
-
- # add pidfile and daemonize
- # daemonize is important for systemd!
- mv prosody.cfg.lua.dist prosody.cfg.lua.old
-
- echo --Important for systemd >> prosody.cfg.lua.dist
- echo -- daemonize is important for systemd. if you set this to false the systemd startup will freeze. >> prosody.cfg.lua.dist
- echo daemonize = true >> prosody.cfg.lua.dist
- echo 'pidfile = "/run/prosody/prosody.pid"'>> prosody.cfg.lua.dist
- echo "" >> prosody.cfg.lua.dist
- cat prosody.cfg.lua.old >> prosody.cfg.lua.dist
- rm prosody.cfg.lua.old
+ ./configure --ostype=linux --prefix=/usr --sysconfdir=/etc/prosody \
+ --datadir=/var/lib/prosody --with-lua-include=/usr/include \
+ --cflags="${CFLAGS} -fPIC -Wall -Wextra -D_GNU_SOURCE" \
+ --ldflags="${LDFLAGS} -shared" --no-example-certs \
+ --runwith=lua \
+ --lua-version=5.4 \
+ --idn-library=icu
}
build() {
cd ${pkgname}
- ./configure --ostype=linux --prefix=/usr --sysconfdir=/etc/prosody \
- --datadir=/var/lib/prosody --with-lua-include=/usr/include/lua5.1 \
- --cflags="${CFLAGS} -fPIC -Wall -Wextra -D_GNU_SOURCE" \
- --ldflags="${LDFLAGS} -shared" --no-example-certs \
- --runwith=lua5.1 \
- --lua-version=5.1
make
}
check() {
cd ${pkgname}
-
make lint
}
@@ -94,6 +85,6 @@ package() {
# vim: ft=sh syn=sh ts=2 sw=2
sha256sums=('SKIP'
- '343d7c61ee1c105d760480e9ba6a0655da6bd1a58335f4264a289ade96cffa4c'
+ 'fb025d8d0608dc9fd5be2fde8528bc4fa10d9e38874a98eaa5c56ca9ae048302'
'e5c30ffbb066f0ed3444475b3313490c535d8c9df018726f6cecf9e3ddfd2e48'
- 'af4ce76ae0a8773429eac53c72f1b87c8fa59c63acf003450f75dcb73131a21c')
+ '40ea4a388ba69568daedde69b636d54747be1452e9d485fe19ee23320e66ada2')