summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ca1c9b76f27..ccd10542ed2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,8 +18,13 @@ pkgdesc="Lightweight and extensible Jabber/XMPP server written in Lua (developme
arch=('i686' 'x86_64' 'armv7h')
url="https://prosody.im/"
license=('MIT')
-depends=('lua52' 'lua52-socket' 'lua52-expat' 'lua52-filesystem' 'libidn'
- 'openssl')
+depends=(
+ 'icu'
+ 'lua52'
+ 'lua52-socket'
+ 'lua52-expat'
+ 'lua52-filesystem'
+ 'openssl')
makedepends=('mercurial')
checkdepends=('luacheck' 'shellcheck' 'lua52-posix' 'lua52-sec')
conflicts=('prosody')
@@ -65,7 +70,8 @@ build() {
--cflags="${CFLAGS} -fPIC -Wall -Wextra -D_GNU_SOURCE" \
--ldflags="${LDFLAGS} -shared" --no-example-certs \
--runwith=lua5.2 \
- --lua-version=5.2
+ --lua-version=5.2 \
+ --idn-library=icu
make
}