summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 603377a2871c..aeded3cd48cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton
-_srctag=9.0-1
+_srctag=9.0-2
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.4
-_monover=8.1.0
+_monover=9.1.0
+_xaliaver=0.4.2
pkgrel=1
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
@@ -34,9 +35,12 @@ depends=(
python
steam-native-runtime
)
+depends+=(
+ wayland lib32-wayland
+)
makedepends=(autoconf bison perl flex mingw-w64-gcc
- git wget rsync mingw-w64-tools lld nasm
+ git wget rsync unzip mingw-w64-tools lld nasm
meson cmake fontforge afdko python-pefile
glslang vulkan-headers
clang
@@ -82,6 +86,7 @@ source=(
proton::git+https://github.com/ValveSoftware/Proton.git#tag=proton-${_srctag}
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
+ https://github.com/madewokherd/xalia/releases/download/xalia-${_xaliaver}/xalia-${_xaliaver}-net48-mono.zip
0001-AUR-Pkgbuild-changes.patch
0002-AUR-Do-not-update-cargo-crates.patch
0003-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
@@ -91,6 +96,7 @@ source=(
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
wine-mono-${_monover}-x86.tar.xz
+ xalia-${_xaliaver}-net48-mono.zip
)
_make_wrappers () {
@@ -137,12 +143,13 @@ prepare() {
[ ! -d contrib ] && mkdir -p contrib
mv "$srcdir"/wine-gecko-${_geckover}-x86{,_64}.tar.xz contrib/
mv "$srcdir"/wine-mono-${_monover}-x86.tar.xz contrib/
+ mv "$srcdir"/xalia-${_xaliaver}-net48-mono.zip contrib/
# Explicitly set origin URL for submodules using relative paths
git remote set-url origin https://github.com/ValveSoftware/Proton.git
git submodule update --init --filter=tree:0 --recursive
- for rustlib in gst-plugins-rs media-converter; do
+ for rustlib in gst-plugins-rs; do
pushd $rustlib
export RUSTUP_TOOLCHAIN=stable
export CARGO_HOME="${SRCDEST}"/proton-cargo
@@ -211,8 +218,7 @@ package() {
# For some unknown to me reason, 32bit vkd3d (not vkd3d-proton) always links
# to libgcc_s_dw2-1.dll no matter what linker options I tried.
# Copy the required dlls into the package, they will be copied later into the prefix
- # by the patched proton script. Bundling the helps to avoid making mingw-w64-gcc package
- # a runtime dependency.
+ # by the patched proton script. Bundle them to not depend on mingw-w64-gcc being installed.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
"$_compatdir/${pkgname}"/files/lib/vkd3d/
cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
@@ -245,13 +251,13 @@ package() {
$(find "$_monodir" -iname "*x86_64.dll" -or -iname "*x86_64.exe")
}
-sha256sums=('ced1b467da5f7b4ff0cbc2082d4591346163c9f15a396d879447e5782b4a0e59'
+sha256sums=('2215370461d8beea8d8fda006d1fd206ec1407b90eeff6d3ede5990c2a403d91'
'2cfc8d5c948602e21eff8a78613e1826f2d033df9672cace87fed56e8310afb6'
'fd88fc7e537d058d7a8abf0c1ebc90c574892a466de86706a26d254710a82814'
- '4e3e8a40729e4c9e3e9e651cebe4f1aed8f9a4d22e991e6cd24608687f0eedd4'
- 'f0c3b2490a6d037b72e49f88369aea78ffa6959d3607cbbc77167545c530a1fd'
- 'df84850beefb14e161e5f3c5b6c3ac0557c9b942d56c742c03f25a8ed7efaf0f'
- 'faebb4a50d6a135843b3737b7edfc3eb0d996c61066a146269f5019c5080bbed'
- '3b3d593083e03d2aa01b71418a0a14301401a3d4847713982a882cb0905f6e7b'
- 'acf16bd37b7004a31e3c1c640cf314c4e0e861d9512413d5b095a935540b412d')
-
+ '601169d0203b291fbfd946b356a9538855e01de22abd470ded73baf312c88767'
+ '50ce2cc85162343e62340b0ca7994ceba94592ab395fb99711e94e108e991f0c'
+ '70274a898d45516b90ee0a40a7bb56e84d60900be2adaa165f7a0f605c11d13f'
+ 'f6a29f55aa845f95ed78e183a876d8caeffce3254e3fc61c8bf25f3c2bed483c'
+ '47f7fec21f8f00b4af7ddd82643481232bd4fcbc5021d2f69797717d7a02a41e'
+ '1d41b6e5140da5914a326327b17b1b34bb0d04a201da38bdbce87a04d2b75d32'
+ '8187fea6a7daf9fed0e63292711d79166ffa2b0f110685e4b995f68469531cca')