summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67e59960b666..990775508068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=${_srctag//-/.}
_geckover=2.47.2
_monover=6.3.0
_dxvkver=1.9.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -146,6 +146,7 @@ prepare() {
# Install it from pip in a virtualenv
virtualenv --app-data "$srcdir"/build_venv/cache --no-wheel build_venv
source build_venv/bin/activate
+ pip install --no-cache-dir meson==0.59.3
pip install --no-cache-dir afdko
pip install --no-cache-dir pefile
@@ -281,6 +282,7 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export WINEESYNC=0
export WINEFSYNC=0
+ export DISPLAY=""
SUBJOBS=$([[ "$MAKEFLAGS" =~ -j\ *([1-9][0-9]*) ]] && echo "${BASH_REMATCH[1]}" || echo "$(nproc)") \
make -j1 dist
}