summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b21e82c1074..e4b659b7e43f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-experimental
-_srctag=8.0-20231219
+_srctag=8.0-20240111c
_commit=
-pkgver=8.0.20231219 #${_srctag//-/.}
+pkgver=8.0.20240111.3 #${_srctag//-/.}
_geckover=2.47.4
_monover=8.1.0
-pkgrel=3
+pkgrel=1
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, experimental branch"
url="https://github.com/ValveSoftware/Proton"
@@ -175,9 +175,9 @@ build() {
--proton-sdk-image="" \
--build-name="${pkgname}"
-# local -a split=($CFLAGS)
-# local -A flags
-# for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
@@ -197,8 +197,8 @@ build() {
# https://bugs.winehq.org/show_bug.cgi?id=43516
# AVX is "hard" disabled for 32bit in any case.
# AVX2 for both 32bit and 64bit is disabled below.
- CFLAGS+=" -mno-avx2"
- CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2 -mno-avx"
+ CXXFLAGS+=" -mno-avx2 -mno-avx"
export CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS
@@ -262,10 +262,10 @@ sha256sums=('SKIP'
'2cfc8d5c948602e21eff8a78613e1826f2d033df9672cace87fed56e8310afb6'
'fd88fc7e537d058d7a8abf0c1ebc90c574892a466de86706a26d254710a82814'
'4e3e8a40729e4c9e3e9e651cebe4f1aed8f9a4d22e991e6cd24608687f0eedd4'
- '9dffdab7d53dc81ab82ba86d1f4baa8f85b1fe0410ece76b89295b09aab7fbe0'
- 'f16e8271169cbaca1111e925a02bd0d1dfcfd6a0941435b724734b626689f6c6'
- '42c869c47a3079087125efa94d786c5942cbd518a7ab087770a5c19d2007e0d6'
- '0892daec01d88ae497d1389673931f5aa1a93de56b24eeee6a6beaefcee8943c'
- 'c589f9bf60c27033680036a048374632001eddf8a9ca2277c7ed5893263c2ac9'
- 'eefb327133ee164db6d8002a851b8fad72f9fc2e669f1d58901ebdadbc240823')
+ '0ee535ea77c14b0b1953e5456f1c38659d6eabab2c4afe347e321400edab6daf'
+ '1dbff94c55d48eb878b0ee713dd2bc2ffc23243c7e04a0c941dd1b05430940c7'
+ 'b2e4af3738313c64fb86224398696628e138341b603e3c4f8a5193d1d603c962'
+ 'abf849ef1da423cd1cbbc53925a77fb2c47a74f682448a87ff067edcd4453729'
+ '66fea034536c4183e25838b1133a8b397b6cd6645be3260740040f50bd216bb9'
+ '6d7902abcbccc850db96a362f5f42eecd4c8b8b71cd8cedfc3b880f91536a9c7')