summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fff44b281f8a..c9fc9a3b7fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Jason Stryker <public at jasonstryker dot com>
pkgname=protontricks-git
-pkgver=1.10.5.r11.g68f965f
+pkgver=1.11.1.r2.g1dabf82
pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
arch=('any')
@@ -10,6 +10,7 @@ license=('GPL-3.0-or-later')
depends=('python-pillow' 'python-setuptools' 'python-vdf' 'winetricks')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm'
'python-wheel')
+checkdepends=('appstream' 'desktop-file-utils')
optdepends=('yad: for GUI'
'zenity: fallback for GUI')
provides=("${pkgname%-git}")
@@ -27,6 +28,13 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd "${pkgname%-git}"
+ desktop-file-validate "src/${pkgname%-git}/data/share/applications/${pkgname%-git}.desktop"
+ desktop-file-validate "src/${pkgname%-git}/data/share/applications/${pkgname%-git}-launch.desktop"
+ appstreamcli validate "data/com.github.Matoking.${pkgname%-git}.metainfo.xml"
+}
+
package() {
cd "${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl