summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb13a7aa68eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
+_pkgname=pseudo
+pkgname=$_pkgname-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc=""
+arch=(any)
+url=https://github.com/Freed-Wu/$_pkgname
+license=(GPL3)
+makedepends=(git)
+source=("git+$url")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname" || return 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname" || return 1
+
+ ./configure --bits=64 --prefix=/usr
+}
+
+package() {
+ cd "$_pkgname" || return 1
+
+ make DESTDIR="$pkgdir" install
+}