summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff0c52fc0535..f026fb6adf7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.2.151.0.g88ba25a7
+pkgver=1.2.153.0.gb166f4ab
pkgrel=1
pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)"
url="http://psi-plus.com"
@@ -12,17 +12,19 @@ license=('GPL2')
arch=('i686' 'x86_64')
depends=('qt5-base' 'qt5-webkit' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
'libidn' 'aspell' 'libxss' 'qt5-svg' 'hunspell')
-makedepends=('git' 'patch' 'qconf-git' 'cmake' 'qca-qt4')
+makedepends=('git' 'patch' 'qconf-git' 'cmake')
provides=("psi-plus=$pkgver" "psi-plus-qt5-git=$pkgver")
conflicts=('psi-plus' 'psi-plus-qt5-git' 'psi-plus-webkit-qt5-git' 'psi-plus-webkit-git')
source=("git://github.com/psi-plus/psi-plus-snapshots"
"git://github.com/psi-plus/main.git"
'conf.diff'
- 'join.patch')
+ 'join.patch'
+ 'no-qca-qt4.patch')
sha256sums=('SKIP'
'SKIP'
'690770c7c8976d536d8c4078d01c28f187f510574ddffe91251f5045fa672e53'
- 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974')
+ 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974'
+ 'a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23')
pkgver() {
@@ -38,7 +40,9 @@ prepare() {
# cp -r "$srcdir"/main/iconsets/* ./iconsets
# echo "$pkgver ($(date +"%Y-%m-%d"))" >version
patch -p1 <"$srcdir"/join.patch
-}
+ patch -Np1 -i "${srcdir}//no-qca-qt4.patch"
+ }
+
build() {
cd psi-plus-snapshots