summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a4780944aaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nikarh <nikolajs.arhipovs@gmail.com>
+pkgname=psvita-sdk
+pkgver=1
+pkgrel=1
+pkgdesc="PS vita homebrew sdk"
+arch=('i686' 'x86_64')
+url="https://vitasdk.org/"
+license=('GPL2')
+options=(!strip)
+depends=(
+ 'pacman>5'
+ 'git'
+)
+makedepends=(
+ 'wget'
+)
+source=("sudo-fix.patch" "git+https://github.com/vitasdk/vdpm")
+md5sums=('1213c1c23d734af92553ac8801443d36'
+ 'SKIP')
+
+prepare() {
+ cd "vdpm"
+ patch --forward --strip=1 --input="${srcdir}/sudo-fix.patch"
+}
+
+package() {
+ export VITASDK=$pkgdir/opt/vitasdk
+
+ cd "vdpm"
+ ./bootstrap-vitasdk.sh
+ ./install-all.sh
+}