summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e499704663f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='ptouch-print'
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Command line tool to print labels on Brother P-Touch printers"
+arch=('x86_64')
+url='https://mockmoon-cybernetics.ch/computer/p-touch2430pc/'
+license=('GPL2')
+depends=('gd' 'libusb')
+makedepends=('autoconf' 'git')
+provides=("${pkgname}")
+source=("git+https://mockmoon-cybernetics.ch/cgi/cgit/linux/${pkgname}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname}"
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C "${pkgname}" install
+ #install -Dm644 -t "${pkgdir}/usr/share/man/man1" "${pkgname}/${pkgname}.1"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}/README"
+}
+
+# vim: ts=2 sw=2 et: