summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b15cab5ce25e..b19bb91323b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _datetag=2022111116
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
-pkgrel=3
+pkgrel=4
pkgdesc="Community build of the hackable text editor, built on Electron"
arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
@@ -40,11 +40,15 @@ package() {
# Fix core modules missing in settings. Remove when implemented upstream
sed -i "s/=== 'apm'/=== 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/lib/apm.js"
+ sed -i "s/is 'apm'/is 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/src/apm.coffee"
# Fix featured not working. Remove when implemented upstream
sed -i "/pack != null/c return pack != null && pack.releases != null;" \
"$pkgdir/opt/Pulsar/resources/app/ppm/lib/featured.js"
+ sed -i "s/pack?.releases?.latest?/pack?.releases?/" \
+ "$pkgdir/opt/Pulsar/resources/app/ppm/src/featured.coffee"
+
# This needs removal along with asar makedepend when fixed upstream
mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"