summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 24 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 820091e6ef68..81a158619eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,50 @@
# Maintainer: kballen <ken@kballentine.net>
-pkgname=pulseaudio-module-xrdp-git
-pkgver=0.4.r4.ge9f78c4
+_pkgname=pulseaudio-module-xrdp
+pkgname="${_pkgname}-git"
+pkgver=0.5.r2.g8b3c7f3
pkgrel=1
pkgdesc="PulseAudio modules for xrdp"
arch=('i686' 'x86_64')
url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
-license=('Apache')
+license=('LGPL')
depends=('pulseaudio' 'xrdp')
-makedepends=('git')
+makedepends=('git' 'meson' 'check' 'doxygen' 'perl-xml-parser')
+install="${_pkgname}.install"
conflicts=('pulseaudio-module-xrdp')
provides=('pulseaudio-module-xrdp')
-source=("$pkgname::git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel"
- "git+https://github.com/pulseaudio/pulseaudio.git"
- "xrdp-script.conf")
+_pulseaudio_ver=$(pulseaudio --version | awk '{print $NF}')
+source=("git+https://github.com/neutrinolabs/${_pkgname}.git#branch=devel"
+ "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz")
sha256sums=('SKIP'
- 'SKIP'
- '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+ $(curl -fs "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz.sha256sum" | awk '{print $1}'))
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags --long|sed -E 's,^[^0-9]*,,;s,([0-9]*-g),r\1,;s,-,.,g'
+ cd "$srcdir/$_pkgname"
+
+ git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([0-9]*-g),r\1,;s,-,.,g'
}
prepare() {
- cd "$srcdir/pulseaudio"
- git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
- NOCONFIGURE=1 ./bootstrap.sh
- ./configure
+ cd "$srcdir/pulseaudio-${_pulseaudio_ver}"
+
+ meson build
+ meson compile -C build
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
+
+ sed -i '\#-I $(PULSE_DIR)/src#a -I $(PULSE_DIR)/build \\' src/Makefile.am
+
./bootstrap
- ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ ./configure "PULSE_DIR=$srcdir/pulseaudio-${_pulseaudio_ver}"
make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/${_pkgname}"
- # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
- # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
- # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
- # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
- # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
- # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
- install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+ make DESTDIR="$pkgdir" install
}