summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8591fc960440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+pkgname=puppet-lint
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Check that your Puppet manifests conform to the style guide."
+arch=('i686' 'x86_64')
+url="https://github.com/rodjek/puppet-lint"
+license=('MIT')
+depends=('ruby')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$pkgname-$pkgver.gem)
+noextract=($pkgname-$pkgver.gem)
+sha256sums=('739f566cd4f1e77b92c1191217fdb59ce12353f3ec2703f30933d2bba877b35b')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$pkgname-$pkgver.gem"
+}