summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0800f75b91b1..3c8c870ec988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,6 @@ pkgver=0.5.0_beta3.r1.g73caf3d
pkgrel=1
pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
url="https://source.puri.sm/Librem5/chatty"
-source=("git+https://source.puri.sm/Librem5/chatty.git")
-md5sums=(SKIP)
license=("LGPL2.1")
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
depends=("evolution-data-server"
@@ -29,11 +27,20 @@ provides=("purism-chatty")
conflicts=("purism-chatty")
# Keep the source in a version-independent directory, so on update we simply
# git pull into it.
+source=(
+ "${_pkgname}::git+https://source.puri.sm/Librem5/chatty.git"
+ "latest_olm.patch"
+)
+md5sums=(SKIP c934d64deacfdec2592cea05d1a7f8cc)
pkgver() {
git -C ${_pkgname} describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch --directory=${_pkgname} --forward --strip=1 --input=${srcdir}/latest_olm.patch
+}
+
build() {
# Only setup the build directory if it doesn't exist :
test -d build || arch-meson ${_pkgname} build