summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbd32fda082c..a9a948b79073 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: Thaodan <theodorstormgrade@gmail.com>
-# Contributor: Lázaro Armando <aur at chipojosoft.com>
+# Maintainer: Michael Eliachevitch <m.eliachevitch@posteo.de>
+# Contributor (maintainer of previous -hg version): Thaodan <theodorstormgrade@gmail.com>
+# Contributor (of previous -hg version): Lázaro Armando <aur at chipojosoft.com>
_pkgname=purple-rocketchat
-pkgname=$_pkgname-hg
+pkgname=$_pkgname-git
pkgrel=1
-pkgver=r90.826990b48f41
+pkgver=6.8db8f8e
pkgdesc="A purple (pidgin, finch, ...) plugin for RocketChat services"
depends=( "libpurple" "json-glib" "zlib" "discount>=2.1.7")
-makedepends=('mercurial')
-url="https://bitbucket.org/EionRobb/purple-rocketchat"
+makedepends=('git')
+url="https://github.com/EionRobb/purple-rocketchat"
arch=('i686' 'x86_64')
license=('GPL3')
provides=($_pkgname)
-conflicts=($_pkgname)
-source=('hg+https://bitbucket.org/EionRobb/purple-rocketchat')
+conflicts=($_pkgname $_pkgname-hg)
+replaces=($_pkgname-hg)
+source=('git+https://github.com/EionRobb/purple-rocketchat')
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ cd "$srcdir/$_reponame"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
-
build() {
cd $_pkgname
make