summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1554b089722..08840b200a2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
-pkgver=0.2.2
+pkgver=0.2.5
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
source=('git+https://github.com/jplsek/puush-qt.git')
md5sums=('SKIP')
-makedepends=('git')
+makedepends=('git' 'cmake')
depends=('scrot' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-quickcontrols2')
build() {
cd "$pkgname"
git submodule init
git submodule update
- qmake PREFIX=/usr puush-qt.pro
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr
make
}
package() {
cd "$pkgname"
- make INSTALL_ROOT="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}