summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b716d3d99a6e..d2c81825e75a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
-pkgver=0.2
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
@@ -11,21 +11,16 @@ md5sums=('SKIP')
makedepends=('git')
depends=('scrot' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-quickcontrols2')
-prepare() {
- mkdir "$pkgname"/build
-}
-
build() {
cd "$pkgname"
git submodule init
git submodule update
- cd build
- qmake PREFIX=/usr ../puush-qt.pro
+ qmake PREFIX=/usr puush-qt.pro
make
}
package() {
- cd "$pkgname"/build
+ cd "$pkgname"
make INSTALL_ROOT="$pkgdir" install
}