summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80a9d746417a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jason McGillivray < mcgillivray dot jason at gmail dot com>
+
+
+pkgname=py3status-amdfan
+pkgdesc="Py3status module for monitoring fan and temp of amdgpu video cards"
+pkgver=0.1.0
+pkgrel=1
+arch=('any')
+license=('MIT')
+depends=('python' 'py3status' 'amdfan')
+makedepends=('python-setuptools')
+url="https://github.com/mcgillij/py3status-amdfan"
+source=("https://github.com/mcgillij/py3status-amdfan/releases/download/0.1.0/py3status-amdfan-0.1.0.tar.gz")
+md5sums=('29a3049752241334ab2fa8e7ef9ae28f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}