summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d88d35f08eeb..a0f230ecf40b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: a821
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: bartus
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
# Contributor: Dave Reisner <d@falconindy.com>
-_pkgname=pyalpm
-pkgname=$_pkgname-git
-pkgver=0.8.4.r8.g06fa0ea
+pkgname=pyalpm-git
+_pkgname=${pkgname%-git}
+pkgver=0.10.6.r11.gc8d9eeb
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('x86_64')
-url="https://git.archlinux.org/pyalpm.git/"
-license=('GPL3')
-depends=('python>=3.6' 'pacman>=5')
-makedepends=('git')
-checkdepends=('python-nose')
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-source=('git+https://git.archlinux.org/pyalpm.git')
+url="https://gitlab.archlinux.org/archlinux/pyalpm"
+license=('GPL-3.0-only')
+depends=('python' 'pacman')
+makedepends=('git' 'python-setuptools' 'python-pkgconfig' 'python-wheel' 'python-build' 'python-installer')
+checkdepends=('python-pytest' 'python-pytest-pacman')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -26,18 +29,15 @@ pkgver() {
build() {
cd $_pkgname
-
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd $_pkgname
-
- PYTHONPATH="$(ls -d build/lib.linux-$CARCH-*)" nosetests -v tests
+ PYTHONPATH="$(ls -d build/lib.linux-$CARCH-*)" pytest -v test
}
package() {
cd $_pkgname
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}