summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34e471a4e6a3..049f66f513e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
-# Contributor: Yen Chi Hsuan <yan12125 at gmail.com>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Dave Reisner <d@falconindy.com>
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.1.r0.gda8de1a
+pkgver=0.8.2.r1.g1f95811
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('i686' 'x86_64')
-url="http://projects.archlinux.org/pyalpm.git/"
-license=('GPL')
+url="https://git.archlinux.org/pyalpm.git/"
+license=('GPL3')
depends=('python>=3.6' 'pacman>=5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git')
-source=('git+https://projects.archlinux.org/git/pyalpm.git')
-md5sums=('SKIP')
+source=('git+https://projects.archlinux.org/git/pyalpm.git'
+ bpo33012.patch::'https://patchwork.archlinux.org/patch/544/raw/')
+sha256sums=('SKIP'
+ '8006c0252733f76c2af6f69bdaed20c91d8710cb0ce96ce69650b7518c66064d')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
+prepare() {
+ cd $_pkgname
+
+ patch -Np1 -i ../bpo33012.patch
+}
+
package() {
- cd "$srcdir/$_pkgname"
+ cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1
}