summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ef9fc3486fc..b24b6198ff2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Ethan Reece <aur at ethanreece dot com>
pkgname=pycharm-professional
-pkgver=2022.3.3
-pkgrel=2
+pkgver=2023.1.1
+pkgrel=1
pkgdesc="Python IDE for Professional Developers. Professional Edition"
arch=('x86_64' 'aarch64')
url='https://www.jetbrains.com/pycharm/'
@@ -15,16 +15,15 @@ license=('custom')
backup=("opt/$pkgname/bin/pycharm64.vmoptions"
"opt/$pkgname/bin/idea.properties")
depends=('giflib' 'glibc' 'sh' 'libxtst' 'libxslt' 'libxss' 'nss' 'python' 'libdbusmenu-glib')
+options=('!strip')
source_x86_64=("https://download.jetbrains.com/python/$pkgname-$pkgver.tar.gz")
source_aarch64=("https://download.jetbrains.com/python/$pkgname-$pkgver-aarch64.tar.gz")
source=("pycharm-professional.desktop"
- "charm.desktop"
- "charm")
+ "ltedit.desktop")
sha256sums=('a75264959b06a45ea0801729bc1688bfbd52da3c5fbf3d5b1ad9267860439291'
- '6996b38a3c2ba1e472838d7046a4c54a27822fd647be9ca590457e8c6a2d50c8'
- '2c520f63afffa5ef153077fc61e0c3b15a0a9bf8fd4973164af62ec64626a741')
-sha256sums_x86_64=('50c37aafd9fbe3a78d97cccf4f7abd80266c548d1c7ea4751b08c52810f16f2d')
-sha256sums_aarch64=('795217e215782bd7cf033deced13394b2273cd4c50010a09d1f158f61d3a4353')
+ '41f0e64dc7ec5ab85e7b0df1dc8237b56c94ccf9e4f2fa033eaadcc7756df3d3')
+sha256sums_x86_64=('aaa8d136e47077cfe970a5b42aa2058bb74038c5dab354c9f6ff22bfa3aa327d')
+sha256sums_aarch64=('b50dd7d3573f00474aeddba8863fa3cad22e642dfb6bfe166f1fe35b92d5dd17')
makedepends=('python-setuptools' 'cython')
optdepends=('ipython: For enhanced interactive Python shell inside Pycharm'
'openssh: For deployment and remote connections'
@@ -41,7 +40,6 @@ optdepends=('ipython: For enhanced interactive Python shell inside Pycharm'
build() {
# clean up and compile PyDev debugger used by PyCharm to speedup debugging
find pycharm-${pkgver}/plugins/python/helpers/pydev/ \( -name *.so -o -name *.pyd \) -delete
- sed -i '1s/^/# cython: language_level=3\n/' pycharm-${pkgver}/plugins/python/helpers/pydev/_pydevd_bundle/pydevd_cython.pxd
python pycharm-${pkgver}/plugins/python/helpers/pydev/setup_cython.py build_ext --inplace --force-cython
# for attach debugger
@@ -67,6 +65,7 @@ package() {
mv "pycharm-$pkgver/"* "$pkgdir/opt/$pkgname/"
install -dm 755 "$pkgdir/usr/share/applications"
install -Dm 644 "$pkgname.desktop" "$pkgdir/usr/share/applications/"
+ install -Dm 644 ltedit.desktop "$pkgdir/usr/share/applications/"
install -dm 755 "$pkgdir/usr/share/icons/hicolor/"{128x128,scalable}"/apps/"
install -Dm 644 "$pkgdir/opt/$pkgname/bin/pycharm.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/pycharm.png"
install -Dm 644 "$pkgdir/opt/$pkgname/bin/pycharm.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/pycharm.svg"
@@ -74,8 +73,6 @@ package() {
# exec
install -dm 755 "$pkgdir/usr/bin/"
ln -s "/opt/$pkgname/bin/pycharm.sh" "$pkgdir/usr/bin/pycharm"
+ ln -s "/opt/$pkgname/bin/ltedit.sh" "$pkgdir/usr/bin/ltedit"
- # install charm application - for edit a single file in Pycharm
- install -Dm 755 charm "$pkgdir/usr/bin/"
- install -Dm 644 charm.desktop "$pkgdir/usr/share/applications/"
}