summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cca8bfea086..abcdecaf7f21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
pkgname=pyfa
-pkgver=2.39.2
+pkgver=2.39.3
pkgrel=2
_distname="Pyfa-${pkgver}"
pkgdesc="EVE Online Fitting Assistant"
@@ -20,17 +20,24 @@ source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v$
pyfa.desktop
pyfa-start.sh
0001-python-3.10-compatibility.patch
+ add_broken_warning.patch
)
-sha256sums=('2a16ca0f1c2c34aebe9698aa84cae3695eea509eaa7496011d1bab0f8ac78a1f'
- SKIP SKIP SKIP)
+sha256sums=('e2c168129e19011bf7d138914df87fb5ea85f12a4d253bc6f1740fd1d060c670'
+ SKIP SKIP SKIP SKIP)
build() {
cd "${srcdir}"/"${_distname}"
+
# "Temporary" fix for python310 and wxPython>4.0.6
echo "Applying 0001-python-3.10-compatibility.patch"
patch --binary -l -p1 < ../0001-python-3.10-compatibility.patch
+
+ echo "Applying add_broken_warning.patch"
+ patch --binary -l -p1 < ../add_broken_warning.patch
+
python db_update.py
+ find . -name "__pycache__" -type d -prune -exec rm -r "{}" \;
}
package() {
@@ -52,11 +59,16 @@ package() {
cp -a "${srcdir}"/"${_distname}"/imgs "${pkgdir}"/usr/share/pyfa
cp -a "${srcdir}"/"${_distname}"/service "${pkgdir}"/usr/share/pyfa
cp -a "${srcdir}"/"${_distname}"/utils "${pkgdir}"/usr/share/pyfa
-
+
install -dm755 "${pkgdir}"/usr/share/pixmaps
install -Dm644 "${srcdir}"/"${_distname}"/imgs/gui/pyfa64.png "${pkgdir}"/usr/share/pixmaps/pyfa.png
install -Dm644 "${srcdir}"/pyfa.desktop "${pkgdir}"/usr/share/applications/pyfa.desktop
install -Dm755 "${srcdir}"/pyfa-start.sh "${pkgdir}"/usr/bin/pyfa
+
+ echo -e "\n!!! THIS PACKAGE IS PARTIALLY BROKEN !!!"
+ echo "wxPython, dependency of Pyfa, is incomaptible with python3.10 (for now)."
+ echo "For more details (and place for bug reports) see: https://github.com/pyfa-org/Pyfa/issues/2391"
+ echo -e "Known issues:\n- Implants tab does not work and will keep erroring out until closed\n"
}